eBay
  • Daily Deals
  • Gift Cards
  • Sell
  • Help & Contact
  • Shop Gifts

eBay Community

THE ANSWER CENTER

The Answer Center is your place to ask fellow eBay Community members questions about buying and selling on eBay, and for you to share your best information, tips, and insights to help other members get answers to their own questions.

View All Questions

Choose a topic to view

Marketing Image for Answer Center Section

GROUPS

Groups is a great place to connect with other community members who share similar interests. Give support, share information, and connect with fellow members. Create or join a Group today!

CHOOSE A GROUP TO VIEW

Marketing image for Groups Section

Announcements

The latest news and updates affecting eBay buyers and sellers

Marketing Image for Announcements Section
Go Now

EBAY COMMUNITY POLICIES

Our policies are designed to create a safe and fair environment for all eBay members. Learning what’s allowed can help you avoid unintentionally breaking the rules and helps everyone in working with reliable, trustworthy members.

Marketing image for eBay Community Policies Section
Go Now
Showing results for 
Search instead for 
Do you mean 

My Profile

Welcome!
PEOPLE YOU FOLLOW

Connect with Fellow eBay Community Members!
Register or Sign In Today!

Community Member
Why are pages not displaying correctly?
Posts: 2
Registered: ‎05-20-2009

Pages are not displaying correctly...seems to be a formatting problem?

Other Answers: 3
Community Member
Posts: 12,087
Registered: ‎10-21-2011
Answered
in reply to arolnick2121

I use IE9 with WIN7 no issues here at all. 

inceptions
Community Member
Posts: 13,254
Registered: ‎01-20-2005
Answered
in reply to arolnick2121

Clear your cache and cookies - that will usually resolve the problem pages don't display correctly. If you are using Internet Explorer as your browser, try Firefox or Chrome - and your eBay experience will be much much better and much much faster.


centerhill73
Community Member
Posts: 23,706
Registered: ‎01-23-2011
Answered
[ Edited ]
in reply to arolnick2121

Dunno what your problem could be. Mine are fine.

 

Have you tried checking with a different browser?