eBay
  • Daily Deals
  • Gift Cards
  • Sell
  • Help & Contact
  • Shop Deals

eBay Community

THE ANSWER CENTER

The Answer Center is your place to ask fellow eBay Community members questions about buying and selling on eBay, and for you to share your best information, tips, and insights to help other members get answers to their own questions.

View All Questions

Choose a topic to view

Marketing Image for Answer Center Section

GROUPS

Groups is a great place to connect with other community members who share similar interests. Give support, share information, and connect with fellow members. Create or join a Group today!

CHOOSE A GROUP TO VIEW

Marketing image for Groups Section

Announcements

The latest news and updates affecting eBay buyers and sellers

Marketing Image for Announcements Section
Go Now

EBAY COMMUNITY POLICIES

Our policies are designed to create a safe and fair environment for all eBay members. Learning what’s allowed can help you avoid unintentionally breaking the rules and helps everyone in working with reliable, trustworthy members.

Marketing image for eBay Community Policies Section
Go Now
Showing results for 
Search instead for 
Do you mean 

My Profile

Welcome!
PEOPLE YOU FOLLOW

Connect with Fellow eBay Community Members!
Register or Sign In Today!

Community Member
View Order Details is not working!
Posts: 2
Registered: ‎10-29-2008

I'm also unable to open View Order Details.  I've tried from the list on MyEbay on sold items, and have opened the listing that sold and can't access Order Details that way either.

I'm using Firefox, always have and prefer it over IE.

Hope Ebay gets this fixed!

Other Answers: 2
wewex777
Community Member
Posts: 6
Registered: ‎12-13-2011
Answered
in reply to 1stphonesource.com

It's IE 10,uninstall it back to internet exploer 9 and eveything will be back to normal i just did it and it work!!!

Community Member
Posts: 12,087
Registered: ‎10-21-2011
Answered
in reply to 1stphonesource.com

Sorry can't help I use IE9 and am not having that issue-checked my back up Chrome and it's working fine there too.