eBay
  • Daily Deals
  • Sell
  • Customer Support

eBay Community

THE ANSWER CENTER

The Answer Center is your place to ask fellow eBay Community members questions about buying and selling on eBay, and for you to share your best information, tips, and insights to help other members get answers to their own questions.

View All Questions

Choose a topic to view

GROUPS

Groups is a great place to connect with other community members who share similar interests. Give support, share information, and connect with fellow members. Create or join a Group today!

CHOOSE A GROUP TO VIEW


Announcements

The latest news and updates affecting eBay buyers and sellers

Go Now

EBAY COMMUNITY POLICIES

Our policies are designed to create a safe and fair environment for all eBay members. Learning what’s allowed can help you avoid unintentionally breaking the rules and helps everyone in working with reliable, trustworthy members.

Go Now
Showing results for 
Search instead for 
Do you mean 

My Profile

Welcome!
PEOPLE YOU FOLLOW

Connect with Fellow eBay Community Members!
Register or Sign In Today!

Community Member
503 Service Unavailable
Posts: 1
Registered: ‎12-31-2013

hey. i keep getting "503 Service Unavailable" message when trying to open ebay website. i just get this message with ebay website and this issue still occures since 1 month. any suggestions !! Please advise !!!

Other Answers: 2
jame234
Community Member
Posts: 17,397
Registered: ‎01-13-2011
Answered
in reply to husam.alsalous

husam.alsalous wrote:

hey. i keep getting "503 Service Unavailable" message when trying to open ebay website. i just get this message with ebay website and this issue still occures since 1 month. any suggestions !! Please advise !!!



What browser are you using?  Clear you browsing history, dump your cookies and reboot.  try another browser such as Mozilla Firefox.

jame234
Community Member
Posts: 17,397
Registered: ‎01-13-2011
Answered
in reply to husam.alsalous

What browser are you using?  Clear you browsing history, dump your cookies and reboot.  try another browser such as Mozilla Firefox.